9qihuo.com
我们只提供有用的干货

请老师写一个共振指标 (文华财经)

投资者咨询:请老师写一个共振指标 (文华财经)
来源:文华财经  日期:2020-9-4 15:38
 长期macd20.30.13,短期macd12.26.9
1.短期macd红柱中,长期macd金叉,同时K线(价格收盘价)在30线上方,显示一个向上的红箭头
2.短期macd绿柱中,长期macd死叉,同时K线(价格收盘价)在30线下方,显示一个向下的红箭头
另外macd和均线的数值,方便我自己改动,谢谢老师
技术人员回复
日期:2020-9-4 15:40

参考:


DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA), COLORSTICK;

DIFF1:=EMA(CLOSE,20) - EMA(CLOSE,30);
DEA1:=EMA(DIFF1,13);
MACD1:=2*(DIFF1-DEA1), COLORSTICK;

MA30:MA(C,30);

DRAWTEXT(MACD>0 && CROSS(MACD1,0) && C>MA30,H,'↑'),COLORRED,FONTSIZE25;

DRAWTEXT(MACD<0 && CROSSDOWN(MACD1,0) && C<MA30,H,'↓'),COLORRED,FONTSIZE25;


投资者咨询:请老师写一个共振指标 (文华财经)
来源:文华财经  日期:2020-9-4 15:38
 老师,请重新写一下,去掉长期的
,短期macd12.26.9
1.短期macd红柱中,在上穿30线(收盘价在30线上上方的第一颗K线,显示一个向上的红箭头
2..短期macd-零轴上形成的金叉,也显示一个向上的红箭头
2.短期macd绿柱中,在上穿30线(收盘价在30线下上方的第一颗K线,显示一个向下的红箭头
3.短期macd-零轴下形成的死叉,也显示一个向下的红箭头
另外macd和均线的数值,方便我自己改动,谢谢老师
技术人员回复
日期:2020-9-4 17:34
参考

SHORT:=12;//DIFF参数
LONG:=26;//DIFF参数
M:=9;//DEA参数
N:=30;//均线参数
DIFF:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA:=EMA(DIFF,M);
MACD:=2*(DIFF-DEA), COLORSTICK;
MA30:MA(C,N);

DRAWTEXT(MACD>0 && C>MA30&&COUNT(MACD>0,BARSLASTCOUNT(C>MA30))=1,H,'↑'),COLORRED,FONTSIZE25;
DRAWTEXT(DIFF>0&&CROSS(DIFF,DEA),H,'↑'),COLORRED,FONTSIZE25;
DRAWTEXT(MACD<0 && C<MA30&&COUNT(MACD<0,BARSLASTCOUNT(C<MA30))=1,H,'↓'),COLORRED,FONTSIZE25;
DRAWTEXT(DIFF<0&&CROSSDOWN(DIFF,DEA),H,'↓'),COLORRED,FONTSIZE25;
   
投资者咨询:请老师写一个共振指标 (文华财经)
来源:文华财经  日期:2020-9-4 15:38
 老师,很好,麻烦您在改一下
1.我要把它放在主图里请把向下的箭头离K线稍微远一点点,把向上的箭头放在K线下方跟K线稍微有点距离,这样看着不太乱
2.K线下30和上30的那个箭头出现时来个声音
再次谢谢老师,耽误您休息了
技术人员回复
日期:2020-9-4 18:49
 参考

X:=1;//箭头距离参数
SHORT:=12;//DIFF参数
LONG:=26;//DIFF参数
M:=9;//DEA参数
N:=30;//均线参数
DIFF:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA:=EMA(DIFF,M);
MACD:=2*(DIFF-DEA), COLORSTICK;
MA30:MA(C,N);

DRAWTEXT(MACD>0 && C>MA30&&COUNT(MACD>0,BARSLASTCOUNT(C>MA30))=1,L-X*MINPRICE,'↑'),VALIGN0,COLORRED,FONTSIZE25;
DRAWTEXT(DIFF>0&&CROSS(DIFF,DEA),H,'↑'),COLORRED,FONTSIZE25;
DRAWTEXT(MACD<0 && C<MA30&&COUNT(MACD<0,BARSLASTCOUNT(C<MA30))=1,H+X*MINPRICE,'↓'),VALIGN2,COLORRED,FONTSIZE25;
DRAWTEXT(DIFF<0&&CROSSDOWN(DIFF,DEA),H,'↓'),COLORRED,FONTSIZE25;
MACD>0 && C>MA30&&COUNT(MACD>0,BARSLASTCOUNT(C>MA30))=1,SOUND('A');
DIFF>0&&CROSS(DIFF,DEA),SOUND('A');
MACD<0 && C<MA30&&COUNT(MACD<0,BARSLASTCOUNT(C<MA30))=1,SOUND('A');
DIFF<0&&CROSSDOWN(DIFF,DEA),SOUND('A');
投资者咨询:请老师写一个共振指标 (文华财经)
来源:文华财经  日期:2020-9-4 15:38
 老师你好,把上边这个指标条件中加一个KD,,KD在50以上,DK在50一下

技术人员回复
日期:2020-9-8 22:35
 
参考:

X:=1;//箭头距离参数
SHORT:=12;//DIFF参数
LONG:=26;//DIFF参数
M:=9;//DEA参数
N:=30;//均线参数
DIFF:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA:=EMA(DIFF,M);
MACD:=2*(DIFF-DEA), COLORSTICK;
MA30:MA(C,N);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);//RSV的移动平均
D:SMA(K,3,1);//K值的移动平均

DRAWTEXT(MACD>0 && C>MA30&&COUNT(MACD>0,BARSLASTCOUNT(C>MA30))=1,L-X*MINPRICE,'↑'),VALIGN0,COLORRED,FONTSIZE25;
DRAWTEXT(DIFF>0&&CROSS(DIFF,DEA),H,'↑'),COLORRED,FONTSIZE25;
DRAWTEXT(MACD<0 && C<MA30&&COUNT(MACD<0,BARSLASTCOUNT(C<MA30))=1,H+X*MINPRICE,'↓'),VALIGN2,COLORRED,FONTSIZE25;
DRAWTEXT(DIFF<0&&CROSSDOWN(DIFF,DEA),H,'↓'),COLORRED,FONTSIZE25;
MACD>0 && C>MA30&&COUNT(MACD>0,BARSLASTCOUNT(C>MA30))=1,SOUND('A');
DIFF>0&&CROSS(DIFF,DEA),SOUND('A');
MACD<0 && C<MA30&&COUNT(MACD<0,BARSLASTCOUNT(C<MA30))=1,SOUND('A');
DIFF<0&&CROSSDOWN(DIFF,DEA),SOUND('A');

DRAWTEXT(CROSS(K,D) && K>50 && D>50,H,'↑'),COLORRED,FONTSIZE25;
DRAWTEXT(CROSSDOWN(K,D) && K<50 && D<50,H+X*MINPRICE,'↓'),VALIGN2,COLORRED,FONTSIZE25;
CROSS(K,D) && K>50 && D>50,SOUND('A');
CROSSDOWN(K,D) && K<50 && D<50,SOUND('A');

投资者咨询:请老师写一个共振指标 (文华财经)
来源:文华财经  日期:2020-9-4 15:38
 老师,不是这样的,条件是同时满足KD50以上,MACD红柱中,股价上30,出现向上的红箭头。同时满足KD50以下,MACD绿柱中,股价下30,出现向下的红箭头
技术人员回复
日期:2020-9-9 8:12


股价上30 是什么价格大于30?