9qihuo.com
我们只提供有用的干货

老师帮忙改下瀑布线指标 (文华财经)

投资者咨询:老师帮忙改下瀑布线指标 (文华财经)
来源:文华财经  日期:2020-9-19 12:49
老师帮忙写下程序
5日线和30日线金叉死叉形成的高低点
瀑布线PB1>2>3>4>5>6的情况,价格突破5日线和30日线的金叉点位,并且突破BOLL线的上轨线,提示开多
瀑布线PB6>5>4>3>2>1的情况,价格突破5日线和30日线的死叉点位,并且突破BOLL线的下轨线,提示开空
PB1:(EMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;
PB2:(EMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;
PB3:(EMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;
PB4:(EMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;
PB5:(EMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;
PB6:(EMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3; //定义6条瀑布线 
投资者咨询:老师帮忙改下瀑布线指标 (文华财经)
来源:文华财经  日期:2020-9-19 12:49
顺便加上wh7预警,谢谢老师
技术人员回复
日期:2020-9-19 13:16
参考

PB1:(EMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;
PB2:(EMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;
PB3:(EMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;
PB4:(EMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;
PB5:(EMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;
PB6:(EMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3; //定义6条瀑布线 
MID:MA(CLOSE,26);
TMP2:=STD(CLOSE,26);
TOP:MID+2*TMP2;
BOTTOM:MID-2*TMP2;
MA5:MA(C,5);
MA30:MA(C,30);
DRAWTEXT(PB1>PB2&&PB2>PB3&&PB3>PB4&&PB4>PB5&&PB5>PB6&&CROSS(MA5,MA30)&&C>TOP,H,'开多');
DRAWTEXT(PB1<PB2&&PB2<PB3&&PB3<PB4&&PB4<PB5&&PB5<PB6&&CROSSDOWN(MA5,MA30)&&C<BOTTOM,H,'开空');
PB1>PB2&&PB2>PB3&&PB3>PB4&&PB4>PB5&&PB5>PB6&&CROSS(MA5,MA30)&&C>TOP,NOTICE;
PB1<PB2&&PB2<PB3&&PB3<PB4&&PB4<PB5&&PB5<PB6&&CROSSDOWN(MA5,MA30)&&C<BOTTOM,NOTICE;
投资者咨询:老师帮忙改下瀑布线指标 (文华财经)
来源:文华财经  日期:2020-9-19 12:49
老师,开多的k线变黄色,开空的k线变蓝色。复盘看不出来。谢谢老师
技术人员回复
日期:2020-9-19 13:31
PB1:(EMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;
PB2:(EMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;
PB3:(EMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;
PB4:(EMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;
PB5:(EMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;
PB6:(EMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3; //定义6条瀑布线 
MID:MA(CLOSE,26);
TMP2:=STD(CLOSE,26);
TOP:MID+2*TMP2;
BOTTOM:MID-2*TMP2;
MA5:MA(C,5);
MA30:MA(C,30);
TJ1:=PB1>PB2&&PB2>PB3&&PB3>PB4&&PB4>PB5&&PB5>PB6&&CROSS(MA5,MA30)&&C>TOP;
TJ2:=PB1<PB2&&PB2<PB3&&PB3<PB4&&PB4<PB5&&PB5<PB6&&CROSSDOWN(MA5,MA30)&&C<BOTTOM;
DRAWTEXT(TJ1,H,'开多');
DRAWTEXT(TJ2,H,'开空');
TJ1,NOTICE;
TJ2,NOTICE;
DRAWCOLORKLINE(TJ1,COLORYELLOW,0);
DRAWCOLORKLINE(TJ2,COLORBLUE,0);
投资者咨询:老师帮忙改下瀑布线指标 (文华财经)
来源:文华财经  日期:2020-9-19 12:49
老师,试了下效果不是很好,帮忙把瀑布线条件去了,可以吗?只要其他两条件满足就可以
技术人员回复
日期:2020-9-19 13:55
MID:MA(CLOSE,26);
TMP2:=STD(CLOSE,26);
TOP:MID+2*TMP2;
BOTTOM:MID-2*TMP2;
MA5:MA(C,5);
MA30:MA(C,30);
TJ1:=CROSS(MA5,MA30)&&C>TOP;
TJ2:=CROSSDOWN(MA5,MA30)&&C<BOTTOM;
DRAWTEXT(TJ1,H,'开多');
DRAWTEXT(TJ2,H,'开空');
TJ1,NOTICE;
TJ2,NOTICE;
DRAWCOLORKLINE(TJ1,COLORYELLOW,0);
DRAWCOLORKLINE(TJ2,COLORBLUE,0);
投资者咨询:老师帮忙改下瀑布线指标 (文华财经)
来源:文华财经  日期:2020-9-19 12:49
老师,我说的高低点没说清楚,如图所示
金叉,死叉形成之间的k线最高点和最低点
当最高点被突破后并且突破boll上轨提示开多
当最低点被突破后并且突破boll下轨提示开空
wh7信号提醒


图片点击可在新窗口打开查看
图片点击可在新窗口打开查看 文件名:mmexport1600496830905.png
技术人员回复
日期:2020-9-19 14:43
MID:MA(CLOSE,26);
TMP2:=STD(CLOSE,26);
TOP:MID+2*TMP2;
BOTTOM:MID-2*TMP2;
MA5:MA(C,5);
MA30:MA(C,30);
HH:=REF(HHV(H,BARSLAST(CROSS(MA5,MA30))+1),BARSLAST(CROSS(MA30,MA5))+1);
LL:=REF(LLV(L,BARSLAST(CROSS(MA30,MA5))+1),BARSLAST(CROSS(MA5,MA30))+1);
TJ1:=C>HH&&C>TOP;
TJ2:=C<LL&&C<BOTTOM;
DRAWTEXT(TJ1,H,'开多');
DRAWTEXT(TJ2,H,'开空');
TJ1,NOTICE;
TJ2,NOTICE;
DRAWCOLORKLINE(TJ1,COLORYELLOW,0);
DRAWCOLORKLINE(TJ2,COLORBLUE,0);
投资者咨询:老师帮忙改下瀑布线指标 (文华财经)
来源:文华财经  日期:2020-9-19 12:49
谢谢老师,能帮忙过滤一下吗?金叉,死叉后第一个突破信号保留。