9qihuo.com
我们只提供有用的干货

请求帮助 (文华财经随身行Android   6.0.3(281))

投资者咨询:请求帮助 (文华财经随身行Android   6.0.3(281))
来源:文华财经  日期:2020/7/31 16:42
老师,导入您的指标后,mα¢d下面没有显示数字。

DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA : EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
DRAWNUMBER(CROSS(COUNT(MACD>0,BARPOS)=5,0.5),MACD,5,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,BARPOS)=13,0.5),MACD,13,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,BARPOS)=21,0.5),MACD,21,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,BARPOS)=34,0.5),MACD,34,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,BARPOS)=55,0.5),MACD,55,0,COLORRED);

技术人员回复
日期:2020/7/31 16:44
这里您是要在每次金叉之后重新开始计算5,13,21,34和55

还是说从所有数据以来,第5,13,21,34,55个满足MACD>0的位置标记的

之前给您编写的源码,是按照所有数据来计算的
投资者咨询:请求帮助 (文华财经随身行Android   6.0.3(281))
来源:文华财经  日期:2020/7/31 16:42
mαcd每次金叉死叉开始第一根红柱或绿柱开始。谢谢
技术人员回复
日期:2020/7/31 17:05
 参考:

DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA : EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
JC:=CROSS(DIFF,DEA);
SC:=CROSSDOWN(DIFF,DEA);
N1:=BARSLAST(JC)+1;
N2:=BARSLAST(SC)+1;
DRAWNUMBER(CROSS(COUNT(MACD>0,N2)=5,0.5),MACD,5,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,N2)=13,0.5),MACD,13,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,N2)=21,0.5),MACD,21,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,N2)=34,0.5),MACD,34,0,COLORRED);
DRAWNUMBER(CROSS(COUNT(MACD>0,N2)=55,0.5),MACD,55,0,COLORRED);



DRAWNUMBER(CROSS(COUNT(MACD<0,N1)=5,0.5),MACD,5,0,COLORGREEN),VALIGN0;
DRAWNUMBER(CROSS(COUNT(MACD<0,N1)=13,0.5),MACD,13,0,COLORGREEN),VALIGN0;
DRAWNUMBER(CROSS(COUNT(MACD<0,N1)=21,0.5),MACD,21,0,COLORGREEN),VALIGN0;
DRAWNUMBER(CROSS(COUNT(MACD<0,N1)=34,0.5),MACD,34,0,COLORGREEN),VALIGN0;
DRAWNUMBER(CROSS(COUNT(MACD<0,N1)=55,0.5),MACD,55,0,COLORGREEN),VALIGN0;