9qihuo.com
我们只提供有用的干货

老师好,请改这个放文华 (文华财经WH6赢顺V6.7)

投资者咨询:老师好,请改这个放文华 (文华财经WH6赢顺V6.7)
来源:文华财经  日期:2019/8/24 21:14
 请帮忙把这个指标改成能导入文华使用,谢谢。

DDIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),NODRAW;
DDEA:EMA(DDIF,MID),NODRAW;
DMACD:(DDIF-DDEA)*2,NODRAW;

上市天数:=BARSCOUNT(C); N:=IF(上市天数<90,上市天数-1,90);
基点:=CONST(LLV(L,N)); 基:=CONST(HHV(H,N))-基点;
分:=CONST(LLV(DDIF,N)); 百:=CONST(HHV(DDIF,N))-分;
CC比:=(DDIF-分)/百; XCX:=CC比*基+基点;
DIF:=XCX; NOTEXTDDIF:DIF,NODRAW;
DEA:=EMA(DIF,9); NOTEXTDDEA:DEA,NODRAW;
基准零线:=(0-分)/百*基+基点; NOTEXT基准零线:基准零线,COLORYELLOW,LINETHICK1;
MACD:=(DIF-DEA)*2;
STICKLINE(MACD>=0,基准零线,基准零线+MACD,0,0),NODRAW;
STICKLINE(MACD<0,基准零线,基准零线+MACD,0,0),NODRAW;
DRAWTEXT(ISLASTBAR,基准零线,'零轴'),COLORYELLOW; 
技术人员回复
日期:2019/8/25 8:29
 参考:

DDIF:EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;
DDEA:EMA(DDIF,9),NODRAW;
DMACD:(DDIF-DDEA)*2,NODRAW;

上市天数:=BARSCOUNT(C); 
N:=IF(上市天数<90,上市天数-1,90);
基点:=REFX1(LLV(L,N),10000); 
基:=REFX1(HHV(H,N),10000)-基点;
分:=REFX1(LLV(DDIF,N),10000); 
百:=REFX1(HHV(DDIF,N),10000)-分;
CC比:=(DDIF-分)/百; 
XCX:=CC比*基+基点;
DIF:=XCX; 
NOTEXTDDIF:DIF,NODRAW;
DEA:=EMA(DIF,9); 
NOTEXTDDEA:DEA,NODRAW;
基准零线:=(0-分)/百*基+基点; 
NOTEXT基准零线:基准零线,COLORYELLOW,LINETHICK1;
MACD:=(DIF-DEA)*2;
STICKLINE(MACD>=0,基准零线,基准零线+MACD,0,0),NODRAW;
STICKLINE(MACD<0,基准零线,基准零线+MACD,0,0),NODRAW;
DRAWTEXT(ISLASTBAR,基准零线,'零轴'),COLORYELLOW;