9qihuo.com
我们只提供有用的干货

麻烦老师把它改成文华的指标 (文华财经WH6赢顺V6.7)

投资者咨询:麻烦老师把它改成文华的指标 (文华财经WH6赢顺V6.7)
来源:文华财经  日期:2019/8/24 21:42
麻烦老师改一下
 N(2,100,14)
 MTR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TR,COLORRED;
MDI:DMM*100/TR,COLORGREEN;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW;
16;
30;
 谢谢
技术人员回复
日期:2019/8/25 8:31
您指标中缺少TR的定义 ,是MTR?

参考:

N:=14;
MTR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/MTR,COLORRED;
MDI:DMM*100/MTR,COLORGREEN;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW;
16;
30;