9qihuo.com
我们只提供有用的干货

老师, (文华财经随身行Android   5.8.2(261))

投资者咨询:老师, (文华财经随身行Android   5.8.2(261))
来源:文华财经  日期:2019/8/3 4:47

把指标那根细线加粗,谢谢

TY:=C;
CURRBARSCOUNT:=DATACOUNT-DAYBARPOS+1;
AAL1:=REF(TY,10)=HHV(TY,2*10+1);
BB1:=FILTER(AAL1,10);
CL1:=BACKSET(BB1,10+1);
HDL:=FILTER(CL1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1);
BB2:=FILTER(AA2,10);
CC2:=BACKSET(BB2,10+1);
LDL:=FILTER(CC2,10);
前期高位:REF(C,BARSLAST(HDL)),LINETHICK2,COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=8,前期高位,'箱体高点'),COLORCYAN;
前期低位:REF(L,BARSLAST(LDL)),LINETHICK2,COLORFF0000;
DRAWTEXT(CURRBARSCOUNT=8,前期低位,'箱体低点'),COLORRED;


BP1:=MA(C,1);
BP2:=SMA(SMA(SMA(BP1,2,1),2,1),2,1);
SMA2:=MA(BP2,3);
停损下限:IF(LLV(MA(BP2,8),3)<BP2,LLV(MA(BP2,8),3),BP2),LINETHICK4;
IF(BP2>SMA2,BP2,NULL),COLORRED,LINETHICK4;

X:=2;//如果距离还是较近,可以调大X值,设置为20等数值
DRAWTEXT( CROSS(BP2>SMA2,0.5),L-X,'多'),FONTSIZE36,COLORRED,VALIGN0;
IF(BP2<SMA2,BP2,NULL),COLORGREEN,LINETHICK4;
DRAWTEXT( CROSS(BP2<SMA2,0.5),H+X,'空'),FONTSIZE36,COLORCYAN,VALIGN2;

//STICKLINE1(BP2>停损下限,BP2,停损下限,0.1,0),COLORRED;
//STICKLINE1(BP2<停损下限,BP2,停损下限,0.1,0),COLORGREEN;

SNAKEA:HHV(MA(BP2,1),13),COLORYELLOW;
DRAWCOLORLINE(SNAKEA>REF(SNAKEA,1),SNAKEA,COLORYELLOW,COLORGREEN);
//STICKLINE1(SNAKEA>BP2 AND BP2>SMA2,SNAKEA,BP2,0.1,0),COLORLIGHTGREEN;
//STICKLINE1(SNAKEA>SMA2 AND BP2<SMA2,SNAKEA,SMA2,0.1,0),COLORLIGHTGREEN;

HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AAB:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AAB,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=REFX1(DINGBUTS,10000);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=REFX1(DINGBUTS1,10000);
DINGBU2:=REF(DINGBU1,DDD+1);
MMM:=IF(CURRBARSCOUNT>GDCS2,0,1);
DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1),COLORGREEN,DOT;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,DOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,DOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=REFX1(DDTS1,10000);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=REFX1(DDTS2,10000);
DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1), COLORRED,DOT;
//ZGSTAR:=(高点压力+低点支撑)/2;
//ZGEND:=REFX1((高点压力+低点支撑)/2,10000);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
//DRAWLINE(CURRBARSCOUNT=STARDAY,

技术人员回复
日期:2019/8/3 8:27
您看给您加粗的那条线是否正确

TY:=C;
CURRBARSCOUNT:=DATACOUNT-DAYBARPOS+1;
AAL1:=REF(TY,10)=HHV(TY,2*10+1); 
BB1:=FILTER(AAL1,10); 
CL1:=BACKSET(BB1,10+1); 
HDL:=FILTER(CL1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1); 
BB2:=FILTER(AA2,10); 
CC2:=BACKSET(BB2,10+1); 
LDL:=FILTER(CC2,10);
前期高位:REF(C,BARSLAST(HDL)),LINETHICK2,COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=8,前期高位,'箱体高点'),COLORCYAN;
前期低位:REF(L,BARSLAST(LDL)),LINETHICK2,COLORFF0000;
DRAWTEXT(CURRBARSCOUNT=8,前期低位,'箱体低点'),COLORRED;


BP1:=MA(C,1);
BP2:=SMA(SMA(SMA(BP1,2,1),2,1),2,1);
SMA2:=MA(BP2,3);
停损下限:IF(LLV(MA(BP2,8),3)<BP2,LLV(MA(BP2,8),3),BP2),LINETHICK4;
IF(BP2>SMA2,BP2,NULL),COLORRED,LINETHICK4;

X:=2;//如果距离还是较近,可以调大X值,设置为20等数值
DRAWTEXT( CROSS(BP2>SMA2,0.5),L-X,'多'),FONTSIZE36,COLORRED,VALIGN0;
IF(BP2<SMA2,BP2,NULL),COLORGREEN,LINETHICK4;
DRAWTEXT( CROSS(BP2<SMA2,0.5),H+X,'空'),FONTSIZE36,COLORCYAN,VALIGN2;

//STICKLINE1(BP2>停损下限,BP2,停损下限,0.1,0),COLORRED;
//STICKLINE1(BP2<停损下限,BP2,停损下限,0.1,0),COLORGREEN;

SNAKEA:HHV(MA(BP2,1),13),COLORYELLOW,LINETHICK2;
DRAWCOLORLINE(SNAKEA>REF(SNAKEA,1),SNAKEA,COLORYELLOW,COLORGREEN);
//STICKLINE1(SNAKEA>BP2 AND BP2>SMA2,SNAKEA,BP2,0.1,0),COLORLIGHTGREEN;
//STICKLINE1(SNAKEA>SMA2 AND BP2<SMA2,SNAKEA,SMA2,0.1,0),COLORLIGHTGREEN;

HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AAB:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AAB,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=REFX1(DINGBUTS,10000);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=REFX1(DINGBUTS1,10000);
DINGBU2:=REF(DINGBU1,DDD+1);
MMM:=IF(CURRBARSCOUNT>GDCS2,0,1);
DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1),COLORGREEN,DOT;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,DOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,DOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=REFX1(DDTS1,10000);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=REFX1(DDTS2,10000);
DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1), COLORRED,DOT;
//ZGSTAR:=(高点压力+低点支撑)/2;
//ZGEND:=REFX1((高点压力+低点支撑)/2,10000);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
//DRAWLINE(CURRBARSCOUNT=STARDAY,

投资者咨询:老师, (文华财经随身行Android   5.8.2(261))
来源:文华财经  日期:2019/8/3 4:47
是的老师,把线换成下跌绿色上涨黄色,在粗点,十分感谢
技术人员回复
日期:2019/8/3 9:35
 参考:

TY:=C;
CURRBARSCOUNT:=DATACOUNT-DAYBARPOS+1;
AAL1:=REF(TY,10)=HHV(TY,2*10+1); 
BB1:=FILTER(AAL1,10); 
CL1:=BACKSET(BB1,10+1); 
HDL:=FILTER(CL1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1); 
BB2:=FILTER(AA2,10); 
CC2:=BACKSET(BB2,10+1); 
LDL:=FILTER(CC2,10);
前期高位:REF(C,BARSLAST(HDL)),LINETHICK2,COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=8,前期高位,'箱体高点'),COLORCYAN;
前期低位:REF(L,BARSLAST(LDL)),LINETHICK2,COLORFF0000;
DRAWTEXT(CURRBARSCOUNT=8,前期低位,'箱体低点'),COLORRED;


BP1:=MA(C,1);
BP2:=SMA(SMA(SMA(BP1,2,1),2,1),2,1);
SMA2:=MA(BP2,3);
停损下限:IF(LLV(MA(BP2,8),3)<BP2,LLV(MA(BP2,8),3),BP2),LINETHICK4;
IF(BP2>SMA2,BP2,NULL),COLORRED,LINETHICK4;

X:=2;//如果距离还是较近,可以调大X值,设置为20等数值
DRAWTEXT( CROSS(BP2>SMA2,0.5),L-X,'多'),FONTSIZE36,COLORRED,VALIGN0;
IF(BP2<SMA2,BP2,NULL),COLORGREEN,LINETHICK4;
DRAWTEXT( CROSS(BP2<SMA2,0.5),H+X,'空'),FONTSIZE36,COLORCYAN,VALIGN2;

//STICKLINE1(BP2>停损下限,BP2,停损下限,0.1,0),COLORRED;
//STICKLINE1(BP2<停损下限,BP2,停损下限,0.1,0),COLORGREEN;

SNAKEA:HHV(MA(BP2,1),13),COLORYELLOW,LINETHICK4;
DRAWCOLORLINE(SNAKEA>REF(SNAKEA,1),SNAKEA,COLORYELLOW,COLORGREEN),LINETHICK3;
//STICKLINE1(SNAKEA>BP2 AND BP2>SMA2,SNAKEA,BP2,0.1,0),COLORLIGHTGREEN;
//STICKLINE1(SNAKEA>SMA2 AND BP2<SMA2,SNAKEA,SMA2,0.1,0),COLORLIGHTGREEN;

HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AAB:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AAB,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=REFX1(DINGBUTS,10000);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=REFX1(DINGBUTS1,10000);
DINGBU2:=REF(DINGBU1,DDD+1);
MMM:=IF(CURRBARSCOUNT>GDCS2,0,1);
DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1),COLORGREEN,DOT;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,DOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,DOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=REFX1(DDTS1,10000);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=REFX1(DDTS2,10000);
DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1), COLORRED,DOT;
//ZGSTAR:=(高点压力+低点支撑)/2;
//ZGEND:=REFX1((高点压力+低点支撑)/2,10000);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
//DRAWLINE(CURRBARSCOUNT=STARDAY,

投资者咨询:老师, (文华财经随身行Android   5.8.2(261))
来源:文华财经  日期:2019/8/3 4:47
谢谢谢
投资者咨询:老师, (文华财经随身行Android   5.8.2(261))
来源:文华财经  日期:2019/8/3 4:47
麻烦您改下,那根绿色线为他绿色,里线里有夹杂黄色的,谢谢
技术人员回复
日期:2019/8/3 10:25
夹杂的黄色可能为其他画线的颜色或者是条件为满足时的画线
投资者咨询:老师, (文华财经随身行Android   5.8.2(261))
来源:文华财经  日期:2019/8/3 4:47
可以改绿色的
投资者咨询:老师, (文华财经随身行Android   5.8.2(261))
来源:文华财经  日期:2019/8/3 4:47
呵呵和你交流两次,失败两次,最终别的老师能改好